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Quiz 



How many variables do we need to create this 
graph?
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Which are the differences between the graph 
and the table below?

Series 1 Series 2 Series 3

Category 1 4.3 2.4 2

Category 2 2.5 4.4 2

Category 3 3.5 1.8 3

Category 4 4.5 2.8 5
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How many variables will come out from this 
questionnaire? 



Which is a variable and which is a case?

• Household

• Number of days meat was consumed

• Child

• Mother 

• Household size

• Sex of the household head 



TYPES OF DATA AND 
DESCRIPTIVE STATISTICS



Introduction 

In the social sciences we are usually interested in 

discovering something about a phenomenon. 

Whatever the phenomenon we desire to explain, 

we seek to explain it by collecting data from the 

real world and then using these data to draw 

conclusions about what is being studied.



Variable vs. Cases 

• Case 

statistical unit that is being described 

(household, people, sampled universe)

• Variable 

an indicator that describes a case (sex of the 

household head, age of the person, income 

activity of the household)



Type of variables

Continuous

(Scale)  

Categorical

Interval
ex. Age 1 to n

Ratio
ex. Percentage of 

expenditure 0% to 

100%

Nominal
The categories are 

not ranked  ex. 

1=female, 2=male

Ordinal
The categories are 

ranked (ex. 1=poor, 

2=medium, 3= good)

We work with two types of variables



Type of variables 

Type of variables 
Continuous Categorical 

Ordinal Nominal

Do arithmetic operations on 

values make sense?

Yes No No

Are values ordered? Yes Yes No 

Types of values Numeric Alphanumeric 

codes

Alphanumeric 

codes



Continuous variables

Continuous variables assume numeric values which are 

expressed in a given unit of measurement 

• Income, millimeters of rainfall, kilograms of agricultural 

production, percent of food insecure households, 

Weight-for-height z-score for children,  etc. 

Most importantly, each number (within a variable) has a 

meaning in relation to the other numbers, allowing 

arithmetic comparisons to be drawn



Categorical variables

Categorical variables are used to describe the different 
types of properties the item of interest can have.  Values 
are categories, taking a limited set of values.  

Examples include: 
– Sex of an individual = male or female

– Level of education = primary school, secondary school, university and 
above or no schooling

– Age group of a child = 0-11 months, 12-23 months, 24-35 months, 36-47 
months, 48-59 months

Categories can be denoted numerically or alphabetically

Categorical variables take 2 forms-- nominal and ordinal
variables.



Nominal variables

A nominal measurement scale is a set of mutually 
exclusive categories (only one category can be 

used to describe the subject of interest) that varies 

qualitatively but not quantitatively, for example 
gender, provinces, income sources, etc. 

Codes are labels representing different 

behaviours/ characteristics and they do not imply 
any underlying order.



Ordinal categorical variables

An ordinal measurement scale differs

from a nominal one in that the order

among the original categories is

preserved in the analysis. However

differences between adjacent categories

are not equal.

Examples social class and perception

(bad – medium – good).



Descriptive statistics

Descriptive statistics are the most basic from 
of statistics

They include:
• Summaries of one variable

• Comparisons of two or more variables

These tests are the foundation for more 
advanced statistical techniques



Descriptive statistics 

Continuous Categorical  

Range
Mean 
Median 
Mode

Frequencies
Crosstabs 



First lets discuss descriptives

for continuous variables…



Range 

The range is the spread between the 

smallest and the largest values in a 

distribution



What is a mean?

The (arithmetic) MEAN is the sum of all the 

values divided by the numbers of cases 

Statistics such as mean assume normal 

distributions



Median 

The MEDIAN is the value above and below which half 
of the cases fall, the 50th percentile, i.e. the middle 

value of a set of observations ranked in order.

The median is a measure of central tendency not 
sensitive to outlying values--unlike the mean, which 

can be affected by a few extremely high or low 

values. 

A median does not assume a normal distribution



Mode

The MODE of a distribution is the value of the 

observation occurring most frequently. It can be 

used with all measurement scales.

If several values share the greatest frequency of 

occurrence, each of them is a mode. 



To illustrate these concepts…

Looking at age data from 10 individuals…

• What is the range? 

• What is the mean? 

• What is the median? 

• What is the mode? 

1 2 3 4 5 6 7 8 9 10

12 19 23 26 28 28 28 34 36 38



Now lets discuss descriptives 

for categorical variables…



Analysing categorical data

If you want to look at the relationship between 

two categorical variables:

Mean and median not useful, except for when it 

is a binary variable (0/1)

Instead, we use frequencies and cross-tabs



Descriptives for categorical data

• The most basic descriptive for categorical 

variables is the frequency
• which shows the number of cases

• or % of cases Sex of hh head

Frequency Percent

Valid 

Percent

Cumulative 

Percent
Valid Female 236 18.2 18.2 18.2

Male 1064 81.8 81.8 100.0

Total 1300 100.0 100.0



Descriptives for categorical data

• We can also cross-tabulate categories from one 

variable with categories from a second variable

Continuous (scale) Categorical

Continuous (scale) none
Mean

Median

Categorical
Mean

Median
Frequency  



Example: Scale and nominal 

Food Consumption 

Score

Mean
Residence status IDPs 64.0

Residents 75.0

Others 57.6

Total 67.8



Example: Ordinal and nominal

Food Consumption Groups

poor borderline acceptable

N. of 

cases

Row N % Row N % Row N % Count
Residence status IDPs 7.1% 15.6% 77.3% 946

Residents 2.2% 6.0% 91.8% 580

Others 16.2% 20.2% 63.6% 52

Total 5.6% 12.2% 82.2% 1578



Example… (row %)

What percentage of female headed HHs have acceptable consumption? 

What percentage of male headed HHs have poor food consumption?

What percentage of borderline consumption HHs in total? 

Food Consumption Groups

Poor Borderline Acceptable Total

Row N % Row N % Row N % Row N %

Sex of hh head Female 7.2% 14.8% 78.0% 100.0%

Male 4.7% 9.0% 86.3% 100.0%

Total 5.2% 10.1% 84.8% 100.0%



Example… (column %)

What percentage of poor consumption HHs are female-headed? 

What percentage of acceptable consumption HHs are male-headed?

What percentage of female-headed HHs in total? 

Food Consumption Groups

Poor Borderline Acceptable Total

Column N 

%

Column N 

%

Column N 

%

Column N 

%
Sex of hh head Female 25.4% 26.7% 16.7% 18.2%

Male 74.6% 73.3% 83.3% 81.8%

Total 100.0% 100.0% 100.0% 100.0%



DATA PREPARATION IN 
SPSS



Data view

• Cases and variables

– Case → each row is one case

– Variable → each column is one variable 

– The differences between the two can be 

easily seen by switching from data view to 

variable view in SPSS



Data view



Variable view



Prepare data before export (example EXCEL)



Prepare data before export (example EXCEL)



Importing data in SPSS:

• Open SPSS is as simple as selecting 

• → File → Open → Data

• Select files by type

• Browse and select data

• Open



Clean variable view

• Name: short name, input variables usually refers to section in questionnaire (e.g. s2_3a, 
s2_3b); must be unique

• Type: number=“numeric”, text=“string”, date=“date”

• Width: Maximum number of characters allowed

• Decimals:  Number of decimals (e.g. 2=0.23)

• Labels: description of the variable

• Values:  Codes for categorical (nominal) variables need to be defined

• Missing values: Values that should be excluded during the analysis (e.g. 99= not 
applicable, 88=not known, etc.)

• Width of column: Width how column should appear on the screen

• Alignment: If text = “left”, if number = “right”

• Level of measurement: if number that can be divided = “scale”, if categorical number or 
string = “nominal” (e.g. 1=yes,  0=no) , if rank = “ordinal” (e.g. 1=poor, 2=medium, 3= 
better-off)



Data cleaning

• Cleaning data can be a painful process

• Being systematic about cleaning data from 
the beginning of the process can save hours 
of work later in the analysis

• Some basic tools to use in SPSS to clean 
data:
– Sorting cases in ascending or descending order

– Run quick frequency tables for categorical 
variables

– Identify duplicate cases – shows cases which 
have the same unique identifier



Merging datasets

• For each level of analysis, there is one SPSS dataset 

(e.g. HH-level, child-level, HH-member level, market 

price data); 

• It is possible to link data from various levels by merging 

datasets using the adding variables function;

• It is also possible to combine datasets that collected the 

same indicators (e.g. data from different countries, 

different rounds) using the adding cases function; 



Merging datasets (adding variables)

• For example – the education level of a household head is recorded 

in the household dataset.  We may be interested to find if the 

nutritional status of a child is related to education of the household 

head.  But the child data is in a separate dataset.

• In order to merge the datasets, a common variable must exist in 

each dataset.  In this case, a household identifier must be in both 

datasets.

Household  ID

Education level of 

household head

Household  ID

Weight for Age z-

score (WAZ)

Household dataset Child dataset



Merging datasets (adding cases)

Laos data
Cambodia  data

1. 2.

Laos data

Cambodia data

3.



Create unique codes

• First column: round number (01-…..)

• Second column: region code (01-10)

• Third column: site code (01-25)

• Fourth column: HH number (01-15)

• How many digits will the unique code have?

• _ _(round)_ _(region) _ _(site-code) _ _(HH-number)



Questions?



SPSS COMMANDS FOR 
DESCRIPTIVE ANALYSIS



SPSS commands

• Recode into different variable

• Compute

• Filter

• Custom tables

• Paste syntax



Create new variables using recode

• Recoding a variable is 
the most common 
command we use in 
SPSS
– Into same variable

– Into different variable

• Objective: Classify 
categorical or scale 
variables into groups
– Drinking water sources 

into “improved”/”not 
improved”

– Age into age groups

– FCS into FCS groups

4.2 What is the main source of drinking water for your 
household? 

(Circle one)

•1 = Piped water

•2 = Well (protected)

•3 = Well (unprotected)
•4 = River, stream or pond

•5 = Collecting rainwater

•6 = Tanker truck water

Improved source Unimproved source

Piped water Well (unprotected)

Well (protected) River, stream or pond

Collecting rainwater Tanker truck water



Creating a new variable using compute

• Computing a new 
variable is usually done 
when a mathematical 
formula is used to 
derive a new variable
– E.g calculating total HH 

size by adding age 
groups

– % Female in each HH

– % of dependent HH 
members in each HH 
(dependent <15, 60 
plus)

1.5 Please complete 

the household 

demographics table 

on the right. Record 

the number of 

individuals in each 

age category, 

differentiated by 

males and females.

Age Male Female

a. 0-5 years |__|__| |__|__|

b. 6-14 years |__|__| |__|__|

c. 15-59 
years

|__|__| |__|__|

d. 60 years or 
older

|__|__| |__|__|



Selecting cases using filters

• Often, analysis or data processing should only be 
applied to a subset of the cases in your data

• For example, we might want to run analysis only 
on IDPs

• This is done easily in SPSS using the SELECT 
CASES function

• Select Data > Select Cases and then use the If 
conditional dialog box in the subsequent screen in 
SPSS to write a condition.  In this case: select 
cases if residence status = 1 (assuming IDPs = 1)



Selecting cases using filters

• SPSS will create a filter variable at the end 

of the dataset and only select cases that 

meet the criteria you’ve provided

• Ensure to select all cases from the same 

menu once you’ve finished the analysis on 

the subset



Frequencies

• Select ANALYZE > Descriptive Statistics > 

Frequencies

Select the variable 

you want to see



Crosstabs

• Select ANALYZE > Descriptive Statistics > 

Crosstabs



Crosstabs

Select the variables you 

want to cross-tabulate

Click on “Cells” to view by 

percentages



Custom tables

• Select > ANALYZE > select TABLES > 

select CUSTOM TABLES



Custom tables

Select the variable you want to 

monitor in the variable list and drag 

and drop it into the columns & rows 

area on the canvas pane



Paste syntax

• We want to repeat steps, it is useful to 

create syntax



Types of variables

Continuous Categorical

SPSS 

terminologies

Scale Ordinal Nominal

Which

mathematical 

function can be 

applied?

- Calculations

(“compute”)

- Categorizing 

(“recode into 

different variable”)

Categorizing 

(“recode into 

different variable”)

Categorizing 

(“recode into 

different variable”)

Is there an order? Yes Yes No 

Types of values Numbers or 

percentages

Codes (order has 

meaning)

Codes (order has 

no meaning)


